Tower issue
Incident Report for WISP Network Status
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 22:14 UTC
Investigating
We are currently investigating an issue with the tower. We're working on this as we speak and rest assured that your service will be back up the soonest time possible.
Posted Oct 26, 2022 - 23:47 UTC
This incident affected: Orillia L3V 5H8 and Happyland L3V 6H3.