EM Tower Offline
Incident Report for WISP Network Status
Resolved
This incident has been resolved.
Posted Oct 05, 2023 - 12:40 UTC
Monitoring
Electrical work is being completed on site and will be offline until around 7pm.
Posted Oct 04, 2023 - 17:27 UTC
This incident affected: Omemee K0L 2W0.