KN Tower Offline
Incident Report for WISP Network Status
Resolved
This incident has been resolved.
Posted Jun 23, 2023 - 15:17 UTC
Identified
KN Tower is currently offline, we are investigating and seeking a prompt resolution.
Posted Jun 23, 2023 - 12:18 UTC
This incident affected: Keene K0L 2G0 and Indian River K0L 2B0.