Honey Rd Tower Repair
Incident Report for WISP Network Status
Resolved
This incident has been resolved.
Posted Jun 12, 2023 - 15:00 UTC
Monitoring
Heavy rains damaged some equipment on HN Tower. Facilities has been notified and are arranging a fix.
Posted Jun 02, 2023 - 19:52 UTC
This incident affected: Colborne K0K 1S0.