Williamson Rd Maintenance
Incident Report for WISP Network Status
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 12:36 UTC
Monitoring
Emergency repairs are being completed on WL Tower this afternoon, service will be intermittent.
Posted Jun 02, 2023 - 15:07 UTC
This incident affected: Cobourg K9A 4J7 and Hamilton Township.