Tower Offline
Incident Report for WISP Network Status
Resolved
Hydro One restored power to the site, services back online.
Posted May 24, 2023 - 20:02 UTC
Identified
We are currently investigating an outage in these areas.
Posted May 24, 2023 - 18:38 UTC
This incident affected: Port Hope L1A 3V7, Campbellcroft L0A 1G0, Millbrook L0A 1G0, and Bewdley K0L 1E0.