Minnetonka Rd Tower Repair
Incident Report for WISP Network Status
Resolved
Radio had to be replaced, service is restored. If issues persist please reach out to us at 877-955-9477.
Posted Jun 05, 2023 - 16:01 UTC
Monitoring
Repairs are being made today to MT Tower in Roseneath. Service should be restored today.
Posted Jun 05, 2023 - 12:38 UTC
This incident affected: Roseneath K0K 2X0, Hickory Island, Keene K0L 2G0, and Indian River K0L 2B0.