Devitts Rd Outage
Incident Report for WISP Network Status
Resolved
This incident has been resolved.
Posted Jun 14, 2023 - 19:47 UTC
Identified
DV Tower has gone offline, we are currently investigating and working toward a resolution.
Posted Jun 14, 2023 - 19:18 UTC
This incident affected: Nestleton Station L0B 1L0.